Thread Rating:
  • 1 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
USB device different
28-09-2011, 12:55 PM,
#1
USB device different
Hi,
im just a newbie, i have the Pinguino PIC32
installed all sw and the last IDE (i tryied with X.2 version too)

but the problem fisrt is about Windows doesn't detect the device and plus it doesn't ask for a driver at first, so i just continued testing the USb connection with the libusb utility and it gives a different ID name and HID general HYbrid usb Device not the Pinguino project ...

What's wrong?

thanks
Tnx
-Dave


Equipment
Board: Pic32 Pinguino rev.B (Proc: 32MX440F256H)
Python: ver. 2.6.6
PyUsb: ver. 0.4.3 win32-py2.6
LibUsb: Driver/DLL ver. 1.2.5.0
Ide: X.2 fixed
OS: Win 7 SP1
Reply
28-09-2011, 08:59 PM,
#2
RE: USB device different
Hi Dave74,
Try to list usb devices with your pinguino in bootloader mode (1/ press RESET button and then USER button together 2/ release first USER button and then RESET button). Do you see your device (04d8:003c Microchip Technology, Inc.) ?
Try to launch x.2 and take a look at pinguino.log ? Is everything OK ?
Régis.



(28-09-2011, 12:55 PM)Dave74 Wrote: Hi,
im just a newbie, i have the Pinguino PIC32
installed all sw and the last IDE (i tryied with X.2 version too)

but the problem fisrt is about Windows doesn't detect the device and plus it doesn't ask for a driver at first, so i just continued testing the USb connection with the libusb utility and it gives a different ID name and HID general HYbrid usb Device not the Pinguino project ...

What's wrong?

thanks

It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
29-09-2011, 02:42 PM,
#3
RE: USB device different
Hi Régis
sorry for be late,
i just tryied to do it, but with ur button sequence no leds flashing.
if the USer button is that one near the mini USB plug then something is wrong cause 2 leds near the USER button (green and yellow) starts to blink only when i
1. push RST then USER
2. and realese first RST then USER

that make leds bliking.
it should be ok.

Just device listing still the same cause it's just what i have done all times before.

results from testlibusb:

----------------
TESTLIBUSB.exe

DLL version: 1.2.5.0
Driver version: 1.2.5.0

bus/device idVendor/idProduct
bus-0/\\.\libusb0-0001--0x04d8-0x003c 04D8/003C
- Manufacturer : Microchip Technology Inc.
- Product : USB HID Bootloader
wTotalLength: 41
bNumInterfaces: 1
bConfigurationValue: 1
iConfiguration: 0
bmAttributes: c0h
MaxPower: 50
bInterfaceNumber: 0
bAlternateSetting: 0
bNumEndpoints: 2
bInterfaceClass: 3
bInterfaceSubClass: 0
bInterfaceProtocol: 0
iInterface: 0
bEndpointAddress: 81h
bmAttributes: 03h
wMaxPacketSize: 64
bInterval: 1
bRefresh: 0
bSynchAddress: 0
bEndpointAddress: 01h
bmAttributes: 03h
wMaxPacketSize: 64
bInterval: 1
bRefresh: 0
bSynchAddress: 0


--------------------
pinguino log
--------------------

Pinguino started at Thu Sep 29 14:36:00 2011
WX python successfully loaded
WX.AUI successfully loaded
Editeur successfully loaded
Regex successfully loaded
Shutil successfully loaded
Subprocess successfully loaded
Threading successfully loaded
GetText successfully loaded
Locale successfully loaded
WebBrowser successfully loaded
AgParse successfully loaded
Serial successfully loaded


seem all ok but the device in usb isn't recognised..

some Ideas?

Thanks



-----------------------------------------------------------------



(28-09-2011, 08:59 PM)regis Wrote: Hi Dave74,
Try to list usb devices with your pinguino in bootloader mode (1/ press RESET button and then USER button together 2/ release first USER button and then RESET button). Do you see your device (04d8:003c Microchip Technology, Inc.) ?
Try to launch x.2 and take a look at pinguino.log ? Is everything OK ?
Régis.



(28-09-2011, 12:55 PM)Dave74 Wrote: Hi,
im just a newbie, i have the Pinguino PIC32
installed all sw and the last IDE (i tryied with X.2 version too)

but the problem fisrt is about Windows doesn't detect the device and plus it doesn't ask for a driver at first, so i just continued testing the USb connection with the libusb utility and it gives a different ID name and HID general HYbrid usb Device not the Pinguino project ...

What's wrong?

thanks



Attached Files Thumbnail(s)
   
Tnx
-Dave


Equipment
Board: Pic32 Pinguino rev.B (Proc: 32MX440F256H)
Python: ver. 2.6.6
PyUsb: ver. 0.4.3 win32-py2.6
LibUsb: Driver/DLL ver. 1.2.5.0
Ide: X.2 fixed
OS: Win 7 SP1
Reply
29-09-2011, 04:12 PM,
#4
RE: USB device different
Hi,
If the 2 leds are blinking then it's OK, you entered in bootloader mode.
Your computer "see" your Pinguino. The IDE works also fine.
Sorry, I don't understand where is exactly the problem ?
Did you try to load a program, compile it and then upload it ?
Is there any issue at this very last moment ?
Régis

(29-09-2011, 02:42 PM)Dave74 Wrote: Hi Régis
sorry for be late,
i just tryied to do it, but with ur button sequence no leds flashing.
if the USer button is that one near the mini USB plug then something is wrong cause 2 leds near the USER button (green and yellow) starts to blink only when i
1. push RST then USER
2. and realese first RST then USER

that make leds bliking.
it should be ok.

Just device listing still the same cause it's just what i have done all times before.

results from testlibusb:

----------------
TESTLIBUSB.exe

DLL version: 1.2.5.0
Driver version: 1.2.5.0

bus/device idVendor/idProduct
bus-0/\\.\libusb0-0001--0x04d8-0x003c 04D8/003C
- Manufacturer : Microchip Technology Inc.
- Product : USB HID Bootloader
wTotalLength: 41
bNumInterfaces: 1
bConfigurationValue: 1
iConfiguration: 0
bmAttributes: c0h
MaxPower: 50
bInterfaceNumber: 0
bAlternateSetting: 0
bNumEndpoints: 2
bInterfaceClass: 3
bInterfaceSubClass: 0
bInterfaceProtocol: 0
iInterface: 0
bEndpointAddress: 81h
bmAttributes: 03h
wMaxPacketSize: 64
bInterval: 1
bRefresh: 0
bSynchAddress: 0
bEndpointAddress: 01h
bmAttributes: 03h
wMaxPacketSize: 64
bInterval: 1
bRefresh: 0
bSynchAddress: 0


--------------------
pinguino log
--------------------

Pinguino started at Thu Sep 29 14:36:00 2011
WX python successfully loaded
WX.AUI successfully loaded
Editeur successfully loaded
Regex successfully loaded
Shutil successfully loaded
Subprocess successfully loaded
Threading successfully loaded
GetText successfully loaded
Locale successfully loaded
WebBrowser successfully loaded
AgParse successfully loaded
Serial successfully loaded


seem all ok but the device in usb isn't recognised..

some Ideas?

Thanks



-----------------------------------------------------------------



(28-09-2011, 08:59 PM)regis Wrote: Hi Dave74,
Try to list usb devices with your pinguino in bootloader mode (1/ press RESET button and then USER button together 2/ release first USER button and then RESET button). Do you see your device (04d8:003c Microchip Technology, Inc.) ?
Try to launch x.2 and take a look at pinguino.log ? Is everything OK ?
Régis.



(28-09-2011, 12:55 PM)Dave74 Wrote: Hi,
im just a newbie, i have the Pinguino PIC32
installed all sw and the last IDE (i tryied with X.2 version too)

but the problem fisrt is about Windows doesn't detect the device and plus it doesn't ask for a driver at first, so i just continued testing the USb connection with the libusb utility and it gives a different ID name and HID general HYbrid usb Device not the Pinguino project ...

What's wrong?

thanks

It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
29-09-2011, 04:24 PM, (This post was last modified: 29-09-2011, 05:46 PM by Dave74.)
#5
RE: USB device different
Hello again,
Sure Regis, i did load "blink" program then i did compiled and when i pushed to Upload (selected the blink file name from directory as shown) it says "blink.hex opened" then i need to change PRODUCT ID as 000C (cause it show the default one) and then
i push to WRITE.

and nothing happens


in the black window it say this: (view in attachment file)


Attached Files Thumbnail(s)
   
Tnx
-Dave


Equipment
Board: Pic32 Pinguino rev.B (Proc: 32MX440F256H)
Python: ver. 2.6.6
PyUsb: ver. 0.4.3 win32-py2.6
LibUsb: Driver/DLL ver. 1.2.5.0
Ide: X.2 fixed
OS: Win 7 SP1
Reply
29-09-2011, 06:40 PM,
#6
RE: USB device different
I think was an error since the first install, cause when i did plugged the usb at first time, win XP didn't asked me for a driver but just recognized as HID USB interface. So maybe the IDE or LIBUSB driver can't find it like the right manufacturer.

I don't know where to look about it i did search for some INI files or settings but isn't clear how to do.

Let me know if you got some better ideas

Thanks
Tnx
-Dave


Equipment
Board: Pic32 Pinguino rev.B (Proc: 32MX440F256H)
Python: ver. 2.6.6
PyUsb: ver. 0.4.3 win32-py2.6
LibUsb: Driver/DLL ver. 1.2.5.0
Ide: X.2 fixed
OS: Win 7 SP1
Reply
29-09-2011, 06:44 PM,
#7
RE: USB device different
The message you got means pyusb is not installed.


(29-09-2011, 06:40 PM)Dave74 Wrote: I think was an error since the first install, cause when i did plugged the usb at first time, win XP didn't asked me for a driver but just recognized as HID USB interface. So maybe the IDE or LIBUSB driver can't find it like the right manufacturer.

I don't know where to look about it i did search for some INI files or settings but isn't clear how to do.

Let me know if you got some better ideas

Thanks

It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
29-09-2011, 06:46 PM, (This post was last modified: 29-09-2011, 06:57 PM by regis.)
#8
RE: USB device different
Just a minute, I thought you were using a PInguino 32 but on the snapshot I see the compilation is for 8-bit Pinguino. What board do you have ?
Go to Preferences > Board and choose your board.
The message you got means actually that IDE expect one board but can not find it because you use another one.


(29-09-2011, 06:44 PM)regis Wrote: The message you got means pyusb is not installed.


(29-09-2011, 06:40 PM)Dave74 Wrote: I think was an error since the first install, cause when i did plugged the usb at first time, win XP didn't asked me for a driver but just recognized as HID USB interface. So maybe the IDE or LIBUSB driver can't find it like the right manufacturer.

I don't know where to look about it i did search for some INI files or settings but isn't clear how to do.

Let me know if you got some better ideas

Thanks

It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
29-09-2011, 08:38 PM,
#9
RE: USB device different
i got pinguino 32 rev B

i just used PICUNO EQUO or tryied with generic 18F4550 ,cause using PIC 32 Pinguino i got compiling errors.
About PyUsb i installed it , or in pinguino log ill find some failures,

but it's all ok like u can see on first post at the top

Tnx
-Dave


Equipment
Board: Pic32 Pinguino rev.B (Proc: 32MX440F256H)
Python: ver. 2.6.6
PyUsb: ver. 0.4.3 win32-py2.6
LibUsb: Driver/DLL ver. 1.2.5.0
Ide: X.2 fixed
OS: Win 7 SP1
Reply
30-09-2011, 02:39 PM,
#10
USB device not defined
Hello Regis,
i'm trying to unzip again X.2.zip and W32.zip .
i got a question:
after unpacked x.2.zip file in a new folder i have to unpack w32.zip into the same folder right?

it means x2 flder ill get another folder named win32 with inside 2 folders named p8 and p32 , so i can leave them inside to win32 folder or i must copy both folders (p8 ,p32) overwriting existing in main folder ?


Tnx
-Dave


Equipment
Board: Pic32 Pinguino rev.B (Proc: 32MX440F256H)
Python: ver. 2.6.6
PyUsb: ver. 0.4.3 win32-py2.6
LibUsb: Driver/DLL ver. 1.2.5.0
Ide: X.2 fixed
OS: Win 7 SP1
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)