Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu setup with the Olimex 32 bit board
19-12-2011, 04:32 AM,
#1
Ubuntu setup with the Olimex 32 bit board
Hi
I've given up on Lion support for now and am trying to get Pinguino running on my linux box - I've downloaded the testing version x.2.tar.bz2 and the libraries linux.tar.bz2.

The x.2.tar went into a pinguino directory and the linux/p{8.32} from the linux.tar.bz2 are inside the pinguino folder.

I've copied the extra/{26,42}* rules into the /etc/udev/rules.d/ directory and unplugged and replugged my board and put it into bootloader mode.

I'm now at this point, it seems to me that the bootloader is not being configured correctly (?):
lsusb says:
Bus 002 Device 003: ID 04d8:003c Microchip Technology, Inc.

but dmesg says:
[23656.748173] usb 2-2: new full speed USB device using uhci_hcd and address 3
[23656.938211] generic-usb 0003:04D8:003C.0005: hiddev0,hidraw3: USB HID v1.11 Device [Microchip Technology Inc. USB HID Bootloader] on usb-0000:00:1d.0-2/input0
[23691.214164] usb 2-2: usbfs: interface 0 claimed by usbhid while 'docker' sets config #2
r

and the pinguino says:
Processing device 003
Impossible to change the device configuration.

Any help appreciated.
Followup: I checked my udev rule and it does have the same vendor ID and product ID as lsusb shows for my bootloader, since the only thing that the rule sets is the group, I checked that via `ls -lR /dev` and it shows 'root:plugdev' for that device ID under /dev/bus/usb/002:
drat!
Reply
19-12-2011, 11:01 AM,
#2
RE: Ubuntu setup with the Olimex 32 bit board
Add yourself to this group.
Régis.

(19-12-2011, 04:32 AM)raygeeknyc Wrote: Hi
I've given up on Lion support for now and am trying to get Pinguino running on my linux box - I've downloaded the testing version x.2.tar.bz2 and the libraries linux.tar.bz2.

The x.2.tar went into a pinguino directory and the linux/p{8.32} from the linux.tar.bz2 are inside the pinguino folder.

I've copied the extra/{26,42}* rules into the /etc/udev/rules.d/ directory and unplugged and replugged my board and put it into bootloader mode.

I'm now at this point, it seems to me that the bootloader is not being configured correctly (?):
lsusb says:
Bus 002 Device 003: ID 04d8:003c Microchip Technology, Inc.

but dmesg says:
[23656.748173] usb 2-2: new full speed USB device using uhci_hcd and address 3
[23656.938211] generic-usb 0003:04D8:003C.0005: hiddev0,hidraw3: USB HID v1.11 Device [Microchip Technology Inc. USB HID Bootloader] on usb-0000:00:1d.0-2/input0
[23691.214164] usb 2-2: usbfs: interface 0 claimed by usbhid while 'docker' sets config #2
r

and the pinguino says:
Processing device 003
Impossible to change the device configuration.

Any help appreciated.
Followup: I checked my udev rule and it does have the same vendor ID and product ID as lsusb shows for my bootloader, since the only thing that the rule sets is the group, I checked that via `ls -lR /dev` and it shows 'root:plugdev' for that device ID under /dev/bus/usb/002:
drat!

It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
19-12-2011, 03:20 PM,
#3
RE: Ubuntu setup with the Olimex 32 bit board
+1 but also when you add a new group to any user it doesn't affect any current login sessions of the user (so generally you need to log out & then back in).

(Sorry if you already know that.)

John
Reply
21-12-2011, 10:36 AM,
#4
RE: Ubuntu setup with the Olimex 32 bit board
And select PiC32-PINGUINO-OTG in the 'preferences menu'/'board'


(19-12-2011, 04:32 AM)raygeeknyc Wrote: Hi
I've given up on Lion support for now and am trying to get Pinguino running on my linux box - I've downloaded the testing version x.2.tar.bz2 and the libraries linux.tar.bz2.

The x.2.tar went into a pinguino directory and the linux/p{8.32} from the linux.tar.bz2 are inside the pinguino folder.

I've copied the extra/{26,42}* rules into the /etc/udev/rules.d/ directory and unplugged and replugged my board and put it into bootloader mode.

I'm now at this point, it seems to me that the bootloader is not being configured correctly (?):
lsusb says:
Bus 002 Device 003: ID 04d8:003c Microchip Technology, Inc.

but dmesg says:
[23656.748173] usb 2-2: new full speed USB device using uhci_hcd and address 3
[23656.938211] generic-usb 0003:04D8:003C.0005: hiddev0,hidraw3: USB HID v1.11 Device [Microchip Technology Inc. USB HID Bootloader] on usb-0000:00:1d.0-2/input0
[23691.214164] usb 2-2: usbfs: interface 0 claimed by usbhid while 'docker' sets config #2
r

and the pinguino says:
Processing device 003
Impossible to change the device configuration.

Any help appreciated.
Followup: I checked my udev rule and it does have the same vendor ID and product ID as lsusb shows for my bootloader, since the only thing that the rule sets is the group, I checked that via `ls -lR /dev` and it shows 'root:plugdev' for that device ID under /dev/bus/usb/002:
drat!

Reply
21-12-2011, 11:28 PM,
#5
RE: Ubuntu setup with the Olimex 32 bit board
(19-12-2011, 03:20 PM)pingotg Wrote: +1 but also when you add a new group to any user it doesn't affect any current login sessions of the user (so generally you need to log out & then back in).

(Sorry if you already know that.)

John

Thanks, I had added myself to that group and had restarted before I posted the message - so it's not that Sad
Reply
22-12-2011, 12:08 AM,
#6
RE: Ubuntu setup with the Olimex 32 bit board
Do you have a HEX file in your 'sources' directory? You should if you compiled at least one program. To make sure it is not a permission problem, try this as root (or using sudo, or su):
Code:
./linux/p32/bin/ubw32 -w "source/main32.hex" -r -n
Also, did you select the right chip in the 'Preferences' > 'Board' menu? This looks just like a message I was getting when I used the 8-bit only beta5 IDE - it could not communicate with a 32-bit Pinguino (or used the wrong options).
Reply
24-12-2011, 05:19 AM,
#7
RE: Ubuntu setup with the Olimex 32 bit board
(22-12-2011, 12:08 AM)Alfred Wrote: Do you have a HEX file in your 'sources' directory? You should if you compiled at least one program. To make sure it is not a permission problem, try this as root (or using sudo, or su):
Code:
./linux/p32/bin/ubw32 -w "source/main32.hex" -r -n
Also, did you select the right chip in the 'Preferences' > 'Board' menu? This looks just like a message I was getting when I used the 8-bit only beta5 IDE - it could not communicate with a 32-bit Pinguino (or used the wrong options).

I decided to get this working all as root to avoid permissions problems - thanks for the tip about choosing the board, I chose the PIC32 Pinguino and now I can verify but when I try to upload the file I get a link error

error while linking path-to/BlinkWithoutDelay.o

closer, closer... Smile I'll double check that I have the libraries, etc. installed according to the directions but any and all debugging help is welcome!
Reply
24-12-2011, 11:57 AM,
#8
RE: Ubuntu setup with the Olimex 32 bit board
Did any other of the samples work? I recall Blink worked but I think I had to change Toggle to toggle or something. I think RealTimeClock worked.
Reply
24-12-2011, 06:29 PM,
#9
RE: Ubuntu setup with the Olimex 32 bit board
Nope - I looked at the IDE code but am too lazy to have it print out the linker messages and I couldn't get the debug flags to do anything... going to reinstall
I've added the rules to udev/rules.d from a previous install

I downloaded the latest x.2.tar.bz2 and linux.bz2

bunzip x.2.tar.bz2
bunzip2 linux.bz2
mkdir pinguino
cd pinguino
tar -xf ../x.2.tar
tar -xf ../linux.tar
chmod a+rx *py
python ./pinguinobetax2.py

OK the IDE comes up
I choose the PIC32 Pinguino board
I open the blink example
hit the green verify button

and the message is
"""
Board: PIC32 Pinguino
Proc: 32MX440F256H
error while linking /home/raymond/Downloads/pinguino/examples/1.Basics/Blink/Blink.o
"""

This happens for every example

If I choose a different board, i.e. one of the generics, I can build
so the problem is related to the libaries or link options used specifically with the PIC32 board


Oh, this is under ubuntu 11, 32 bit
root@pinguino# uname -a
Linux raymond-pink 2.6.38-13-generic #52-Ubuntu SMP Tue Nov 8 16:48:07 UTC 2011 i686 i686 i386 GNU/Linux
Reply
24-12-2011, 06:51 PM,
#10
RE: Ubuntu setup with the Olimex 32 bit board
Hi raygeeknyc,

Try looking at file stdout in folder/directory /source after you have tried to compile the example program. This should give some more information as to the reason for the error message that appears in the output window.
Board = PIC32-Pinguino-OTG Rev C
OS = Linux Unbuntu 11.10 till 26 Apr 2012
OS = Linux Unbuntu 12:04 from 27 Apr 2012
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)