Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
26j50
21-04-2013, 11:10 AM,
#11
RE: 26j50
(20-04-2013, 09:08 PM)Reenew Wrote: Today I got the kit of the Penguin 26j50. (R2 = 150 ohm?)

Yes, R2 was increased to 150 - see this thread: http://forum.pinguino.cc/showthread.php?tid=3826

Quote:blink : pin2 (Ra0) ,pin12(Rc1) ,pin13(Rc2).
pin17(Rc6),pin11(Rc0) no blink .

I am using winxp and X.4 ide .
What can I do?

I think your pin numbers are mixed up :-)

RA0 is named pin 13 but is physically chip pin 2
RC0 is named pin 10 but is physically chip pin 11
RC1 is named pin 11 but is physically chip pin 12
RC2 is named pin 12 but is physically chip pin 13
RC6 is named pin 08 but is physically chip pin 17

This explains why three LEDs blink and two LEDs do not.

For all pin numbering/naming see: http://wiki.pinguino.cc/index.php/PIC18F26J50_Pinguino
Reply
21-04-2013, 03:47 PM,
#12
RE: 26j50
ok
another problem:

after loading a program correctly in the penguino,
the penguino resets itself, and then continues endlessly

Best Regards
Reenew
Reply
22-04-2013, 01:57 AM,
#13
RE: 26j50
Show us your program and then I (or someone else) can try to replicate the issue.
Reply
23-04-2013, 09:40 PM,
#14
RE: 26j50
I'm doing tests with 2 26j50 board, an official one and a self-built, and the problem I have it on a , l 'other works.

we'll see!
Reply
28-04-2013, 02:15 PM,
#15
RE: 26j50
With this program the board bought it works!

If I introduce another exit, the board does not come out more, from the programming mode .......

---------------------]



void setup()
{
// initialize the digital pin USERLED as an output.
/*pinMode(10, OUTPUT);
/*pinMode(11, OUTPUT);*/
pinMode(17, OUTPUT);
pinMode(8, OUTPUT);
pinMode(9, OUTPUT);
pinMode(12, OUTPUT);
}

void loop()
{
toggle(12); // alternate ON and OFF
delay(500); // wait for a second
toggle(12); // alternate ON and OFF
delay(500); // wait for a second

/*digitalWrite(10, HIGH);
delay(500); // wait for a second
digitalWrite(10, LOW);
delay(500); // wait for a second

/* digitalWrite(11, HIGH);
delay(500); // wait for a second
digitalWrite(11, LOW);
delay(500); // wait for a second*/

digitalWrite(17, HIGH);
delay(500); // wait for a second
digitalWrite(17, LOW);
delay(500); // wait for a second

digitalWrite(8, HIGH);
delay(500); // wait for a second
digitalWrite(8, LOW);
delay(500); // wait for a second*/

digitalWrite(9, HIGH);
delay(500); // wait for a second
digitalWrite(9, LOW);
delay(500); // wait for a second

}

-------------------------]

that both the bootloder?

Best Regards
Reenew
Reply
29-04-2013, 02:56 AM,
#16
RE: 26j50
Are you using the same version of the bootloader in both boards? If not, see possibly related posts at http://forum.pinguino.cc/showthread.php?tid=3891
Reply
02-05-2013, 08:23 PM,
#17
RE: 26j50
the pinguino 26j50 by too many problems, you can not 'use.
l' MX220 operates according to you?
otherwise I have to take an arduino !
Reply
03-05-2013, 11:50 AM,
#18
RE: 26j50
Looking at your program, you seem to have commented most of it out:

Code:
/*digitalWrite(10, HIGH);
delay(500); // wait for a second
digitalWrite(10, LOW);
delay(500); // wait for a second

/* digitalWrite(11, HIGH);
delay(500); // wait for a second
digitalWrite(11, LOW);
delay(500); // wait for a second*/

digitalWrite(17, HIGH);
delay(500); // wait for a second
digitalWrite(17, LOW);
delay(500); // wait for a second

digitalWrite(8, HIGH);
delay(500); // wait for a second
digitalWrite(8, LOW);
delay(500); // wait for a second*/

Apart from a problem with the 26J50 board Blink program and the bootloader not starting the program, I've not had any other specific board issues.

I can't comment on the 32 bit Pinguino boards or Arduino boards - I don't own any.
Reply
04-05-2013, 12:05 PM,
#19
RE: 26j50
ok thanks.
Best Regards
Reenew
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)