Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pinguino_MODGPS_exmple_v1.1
30-08-2013, 10:46 PM,
#1
Pinguino_MODGPS_exmple_v1.1
I tried compiling the above sketch, straight from the Olimex website and got this:
"
Board: PIC32 Pinguino OTG
Proc: 32MX440F256H
File: C:\Users\David\Desktop\PinguinoIDE\Pinguino Aug 27 2013\PINGUINO_MODGPS_example_v.1.1\source\source.pde
compiling...
C:\Users\David\Desktop\PinguinoIDE\source\/user.c:169:2: error: interrupt handlers cannot be MIPS16 functions
"

Then on the STDOUT:
"
C:\Users\David\Desktop\PinguinoIDE\source\main32.c

In file included from C:\Users\David\Desktop\PinguinoIDE\source\main32.c:38:0:

C:\Users\David\Desktop\PinguinoIDE\source\/user.c:124:7: warning: conflicting types for 'Tmr1Interrupt'

C:\Users\David\Desktop\PinguinoIDE\source\/user.c:121:36: note: previous implicit declaration of 'Tmr1Interrupt' was here

C:\Users\David\Desktop\PinguinoIDE\source\/user.c: In function 'Tmr1Interrupt':

C:\Users\David\Desktop\PinguinoIDE\source\/user.c:155:7: warning: passing argument 1 of 'print_data' discards qualifiers from pointer target type

C:\Users\David\Desktop\PinguinoIDE\source\/user.c:83:7: note: expected 'char *' but argument is of type 'volatile unsigned char *'

C:\Users\David\Desktop\PinguinoIDE\source\/user.c:169:2: error: interrupt handlers cannot be MIPS16 functions
"
Am I missing something here, some library not included or what?
Thanks.
Reply
30-08-2013, 11:11 PM,
#2
RE: Pinguino_MODGPS_exmple_v1.1
A forum search would have led you to the "[SOLVED]PIC32 MIPS and Interrupt do not work together" thread which contains the solution to your issue.
Reply
31-08-2013, 03:03 AM,
#3
RE: Pinguino_MODGPS_exmple_v1.1
Thanks for your advice. I searched for references to the GPS module code, not the interrupt problem specifically, since I wanted fixes to the whole thing. Just to violate the whole "don't complain" Pinguino ideology, I am not a programmer so chose Pinguino/Arduino because it uses wiring syntax, easy connectivity using working code. I chose working code from the Olimex website, a working IDE from Olimex... so you can easily understand why I feel a tad let down by these events. Perhaps with the added experience gained by a 2nd day of using the tools, things will improve.
Reply
31-08-2013, 08:45 AM, (This post was last modified: 31-08-2013, 08:47 AM by pingotg.)
#4
RE: Pinguino_MODGPS_exmple_v1.1
You must be using a newer IDE than the sample. Someone changed the makefile so it no longer works in various ways - like this.

If you want a more mature project go with Arduino. More expensive but not bleeding edge.

John
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)