Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] DIY Pinguino 2550/4550 work on XP, not on win7
29-09-2013, 12:38 PM, (This post was last modified: 04-12-2013, 10:24 AM by dkmorb.)
#1
[SOLVED] DIY Pinguino 2550/4550 work on XP, not on win7
Hi all, I'm new here.

I have a strange problem on my Win7 64bit laptop:
my two Pinguino DIY boards (bootloader ver 4.9) don't work correctly because Pinguino IDE doesn't seem to find the boards (black lines in prompt when I pressed on .
I see the boards in the device manager, named as "Libusb-win32 devices -> Pinguino project".

I check solutions around the forum:

1) http://forum.pinguino.cc/showthread.php?...=windows+7
2) used installer driver supplied by zip package (rev857)
3) disabled driver signature check
4) launched Pinguino IDE as Administrator

but nothing works.

I don't know why all works greatly under Win XP.
Any ideas are apreciated.

Bye
Reply
29-09-2013, 07:28 PM,
#2
RE: DIY Pinguino 2550/4550 work on XP, not on win7
Ok, i'm investigating in mphidflash.exe code; i 've build it with mingw under win7 64 bit and debbuging I found this error:
Code:
Error number from SetupDiEnumDeviceInterfaces: 259
C:\cb_mphidflash\bin\Debug\cb_mphidflash.exe Error: Device not found (is device attached and in Bootloader mode?)

I'll study in deep this night :-)
Reply
29-09-2013, 07:56 PM,
#3
RE: DIY Pinguino 2550/4550 work on XP, not on win7
IF i remember well, i had quite a bit of trouble to install and get it to work on "rWINdows" 7( a 64 processor as well).
Hope u can manage to sort it soon ! In the end, just following the instructions proerly worked for me( i hadnt followed it properly first few times Smile .
Bless)
Reply
29-09-2013, 08:18 PM,
#4
RE: DIY Pinguino 2550/4550 work on XP, not on win7
(29-09-2013, 07:56 PM)iyahdub Wrote: IF i remember well, i had quite a bit of trouble to install and get it to work on "rWINdows" 7( a 64 processor as well).
Hope u can manage to sort it soon ! In the end, just following the instructions proerly worked for me( i hadnt followed it properly first few times Smile .
Bless)

WOW...which of the thousands of instructions did you follow? Can you provide me a link, a wiki page...?

Thanks!!!
Reply
30-09-2013, 12:52 AM, (This post was last modified: 30-09-2013, 12:53 AM by iyahdub.)
#5
RE: DIY Pinguino 2550/4550 work on XP, not on win7
Wiki ones, if my memory serves me well ?!
http://wiki.pinguino.cc/index.php/Windows_7
Reply
30-09-2013, 09:40 PM, (This post was last modified: 30-09-2013, 09:55 PM by dkmorb.)
#6
RE: DIY Pinguino 2550/4550 work on XP, not on win7
(30-09-2013, 12:52 AM)iyahdub Wrote: Wiki ones, if my memory serves me well ?!
http://wiki.pinguino.cc/index.php/Windows_7

No way, man! :-( -> Frustration

I'm trying to debug mphidflash.exe and I obtain this:

Quote:Pinguino board found! Found: \\?\usb#vid_04d8&pid_feaa#5&28424092&0&1#{a5dcbf10-
6530-11d2-901f-00c04fb951ed}
USB HID device foundSending:
02 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00

About to write
usbdevhandle: 332, usbBuf: 4223265, len: 1, 0
usb write failed, Error 1

C:\projects\mphidflash.exe Error: USB write error

So, someone had more luck than me:
http://forum.pinguino.cc/showthread.php?tid=3805

Changing usb port...still nothing.
Grrr! Angry
Reply
01-10-2013, 09:30 PM,
#7
RE: DIY Pinguino 2550/4550 work on XP, not on win7
I've debug libusb 1.2.6...
Quote:libusb0-sys:[DriverEntry] [loading-driver] v1.2.6.0
libusb0-sys:[add_device] device #1 created for usb\vid_04d8&pid_feaa&rev_0409
libusb0-sys:[reg_get_properties] using default device interface guid.
libusb0-sys:dbg [reg_get_properties] reg-key-name=\REGISTRY\MACHINE\SYSTEM\ControlSet001\Enum\USB\VID_04D8&PID_FEAA\5&2f2efa25&0&1\Device Parameters
libusb0-sys:[set_filter_interface_key] updated interface registry with LUsb0 direct-access symbolic link. id=1
libusb0-sys:[add_device] updated interface registry with LUsb0 direct-access symbolic link. id=0001
libusb0-sys:dbg [add_device] [normal-mode] id=#1 usb\vid_04d8&pid_feaa&rev_0409
libusb0-sys:[add_device] complete status=00000000
libusb0-sys:[dispatch_pnp] IRP_MN_START_DEVICE: is-filter=N usb\vid_04d8&pid_feaa&rev_0409
libusb0-sys:dbg [on_start_complete] is-filter=N usb\vid_04d8&pid_feaa&rev_0409
libusb0-sys:dbg [on_start_complete] applying active configuration for usb\vid_04d8&pid_feaa&rev_0409
libusb0-sys:[set_configuration] setting configuration index 0 timeout=5000
libusb0-sys:[get_descriptor] buffer size: 18 type: 0001 recipient: 0000 index: 0000 language id: 0000 timeout: 5000
libusb0-sys:dbg [call_usbd_ex] status = 00000000h
libusb0-sys:[get_descriptor] buffer size: 9 type: 0002 recipient: 0000 index: 0000 language id: 0000 timeout: 5000
libusb0-sys:dbg [call_usbd_ex] status = 00000000h
libusb0-sys:[get_descriptor] buffer size: 32 type: 0002 recipient: 0000 index: 0000 language id: 0000 timeout: 5000
libusb0-sys:dbg [call_usbd_ex] status = 00000000h
libusb0-sys:[set_configuration] found interface 0
libusb0-sys:dbg [set_configuration] #1 usb\vid_04d8&pid_feaa&rev_0409 passing configuration request to target-device.
libusb0-sys:dbg [call_usbd_ex] status = 00000000h
libusb0-sys:[update_pipe_info] interface 0
libusb0-sys:[update_pipe_info] EP01h maximum-packet-size=64 maximum-transfer-size=4194304
libusb0-sys:wrn [update_pipe_info] overriding EP01h maximum-transfer-size=65536
libusb0-sys:[update_pipe_info] EP81h maximum-packet-size=64 maximum-transfer-size=4194304
libusb0-sys:wrn [update_pipe_info] overriding EP81h maximum-transfer-size=65536
libusb0-sys:dbg [dispatch_pnp] IRP_MN_QUERY_CAPABILITIES: is-filter=N usb\vid_04d8&pid_feaa&rev_0409
->>>> Stopping bootloader here... <<<<-
libusb0-sys:[dispatch_pnp] IRP_MN_SURPRISE_REMOVAL: is-filter=N usb\vid_04d8&pid_feaa&rev_0409
libusb0-sys:[set_filter_interface_key] updated interface registry with LUsb0 direct-access symbolic link. id=-1
libusb0-sys:[dispatch_pnp] IRP_MN_REMOVE_DEVICE: is-filter=N usb\vid_04d8&pid_feaa&rev_0409
libusb0-sys:[dispatch_pnp] deleting device #1 usb\vid_04d8&pid_feaa&rev_0409
libusb0-sys:[unload] [unloading-driver] v1.2.6.0

So LibUsb driver seems to work correctly... Huh
Reply
01-10-2013, 11:19 PM, (This post was last modified: 01-10-2013, 11:20 PM by dkmorb.)
#8
RE: DIY Pinguino 2550/4550 work on XP, not on win7
Sorry guys,
is my screenshot correct for a pinguino 2550 DIY, according to your experience?

Thanks in advance!


Attached Files Thumbnail(s)
   
Reply
04-12-2013, 10:24 AM,
#9
Wink  RE: DIY Pinguino 2550/4550 work on XP, not on win7
Ok, so I formatted my old AMD X2 desktop computer and installed windows 7 64 bit...with lib_usb 1.2.6 all works great now!!!
Probably, I need to format my laptop too Tongue
Reply
04-12-2013, 06:46 PM,
#10
RE: [SOLVED] DIY Pinguino 2550/4550 work on XP, not on win7
Great ! Welcome back !

(04-12-2013, 10:24 AM)dkmorb Wrote: Ok, so I formatted my old AMD X2 desktop computer and installed windows 7 64 bit...with lib_usb 1.2.6 all works great now!!!
Probably, I need to format my laptop too Tongue
It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)