Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
usb and osx
03-03-2014, 11:35 AM,
#11
RE: usb and osx
it sounds like easy when i read it.
as you said, i ll use olimex 28j60 model because of existing library that i already started to read.
i ll certainly have to ask several questions in a few days!!
thx...
Reply
03-03-2014, 04:02 PM, (This post was last modified: 03-03-2014, 04:04 PM by pingotg.)
#12
RE: usb and osx
(03-03-2014, 06:06 AM)Pinguino Wrote: Pinguino USB CDC does not work with OS X (I've tried with every version since Tiger). It also doesn't work with FreeBSD (I've tried with 7, 8 and 9-stable). In both OS cases it creates the device nodes, but no i/o is possible. So, it almost works Smile

I think it's too easy to say the problem is the OS and not a Pinguino related failure. Other USB CDC implementations I have tried (eg Microchip, MikroElektronika, JAL) do work with both OS X and FreeBSD and PICs. It's on my list of things to look at when I have spare time again ... but don't let that stop someone else having a look.

As for OS X terminal programs, there's screen already installed.

It sounds very like Apple and Bluetooth, where devices work with Android, Linux and Windows but not Apple things. I expect Apple say it's not their fault. Heck of a coincidence, though.

I suppose you just adopt any workaround you can.

John
Reply
30-06-2014, 05:11 PM,
#13
RE: usb and osx
Hi all and maybe goodbye,

I tryed to use http://ublo.ro/pic32-pinguino-otg-enc28j60-example/ to make enc28j60 working.

I m not sure of the result because when i tryed to compile it with X.4 (it is said it works with X.3), it doesn't compile without errors. Now there s a new version under development, i wish what has been done with X.4 will work with the new one.
I managed to compile the program but i had to remove some lines because the loop of program get stucked several times.
So, now i have a loop running but i don't know if it s running properly.
There is no debbugger like when i used mplab to program 16F family PICs.
Usb cdc feature is not working properly on mac (i choose that project because of usb but nobody said that it didn't work and that's why i m working to make ethernet working).
Luckily, i have a PC too, but i can't upload program (certainly because of windows 8 is not supported).
Each time you think you overcome a difficulty, you face a new problem.
I don't blame people who built this project because they did it for free and with lot of good intentions but there is not enough documentation.
I thought when i read descriptions about the pinguino project it would be fine but it s too much work trying just to make basic program working because you don't know where you re going.

So, i think people managed to use the olimex enc28j60 ethernet module with a pinguino otg.
If anyone has any experience or exemple to share, it would be more than welcome, else i think i ll give up.

Thx for the reading...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)