Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
compiling problem
10-08-2014, 06:05 PM,
#1
compiling problem
hi guys,with ide 11.0.1 i have the follow error message:

Processor: 18f2550
/dvpt/pinguino/git-copy/pinguino-compilers/sources/sdcc/src/pic16/main.c:701 setting interrupt vector addresses 0xc00
ERROR: device list pic16devices.txt not found, specify its path via -I<path>
'18f2550' was not found.



My OS is windows 7 64bit, thank you for reply.
daneel
Reply
10-08-2014, 08:29 PM,
#2
RE: compiling problem
(10-08-2014, 06:05 PM)daneel16 Wrote: hi guys,with ide 11.0.1 i have the follow error message:

Processor: 18f2550
/dvpt/pinguino/git-copy/pinguino-compilers/sources/sdcc/src/pic16/main.c:701 setting interrupt vector addresses 0xc00
ERROR: device list pic16devices.txt not found, specify its path via -I<path>
'18f2550' was not found.



My OS is windows 7 64bit, thank you for reply.
daneel

the eta version i downloaded to test a few weeks back was missing a lot of processor files (p32 surely and im gonna guess a few more). Have you checked the processor files for the uC youre using in the directory folder?
The beta version is still a "beta" version, anyway. You still have the 10.4 version which should be more stable ( though i have had problems with interrupts, with it related to the MIPS/ NO MIPS issue). Have u tried it yet, or only the beta version ?
Reply
10-08-2014, 10:31 PM,
#3
RE: compiling problem
(10-08-2014, 08:29 PM)iyahdub Wrote:
(10-08-2014, 06:05 PM)daneel16 Wrote: hi guys,with ide 11.0.1 i have the follow error message:

Processor: 18f2550
/dvpt/pinguino/git-copy/pinguino-compilers/sources/sdcc/src/pic16/main.c:701 setting interrupt vector addresses 0xc00
ERROR: device list pic16devices.txt not found, specify its path via -I<path>
'18f2550' was not found.



My OS is windows 7 64bit, thank you for reply.
daneel

the eta version i downloaded to test a few weeks back was missing a lot of processor files (p32 surely and im gonna guess a few more). Have you checked the processor files for the uC youre using in the directory folder?
The beta version is still a "beta" version, anyway. You still have the 10.4 version which should be more stable ( though i have had problems with interrupts, with it related to the MIPS/ NO MIPS issue). Have u tried it yet, or only the beta version ?

I'll try, thank you sono much
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)