Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Résolu] Impossible de compiler (Linux Mint 17)
09-09-2014, 09:25 PM,
#11
RE: Impossible de compiler (Linux MInt 17)
Après avoir fait sudo chmod a+x /usr/bin/sd*, l'IDE me présente le message d'erreur suivant lorsque j'essaie de compiler:

/dvpt/pinguino/git-copy/pinguino-compilers/sources/sdcc/src/pic16/main.c:701 setting interrupt vector addresses 0xc00
WARNING: The target device seems to support XINST and no #pragma config XINST=OFF was found.
The code generated by SDCC does probably not work when XINST is enabled (possibly by default).
Please make sure to disable XINST.
(If the target does not actually support XINST, please report this as a bug in SDCC.)
sh: 1: gpasm: Permission denied
Processor: 18f4550
sdcc: Calling preprocessor...
sdcc: Generating code...
sdcc: Calling assembler...
Reply
09-09-2014, 11:05 PM,
#12
RE: Impossible de compiler (Linux MInt 17)
Quote:@xapon66
Est-ce que le paquet présent dans les dépots permet aussi de compiler pour les 25K50 (ou 45K50), 26J50 et surtout les 27J53 (ou 47J53) ?

Test effectué : le SDCC de Mageïa compile tout sans broncher.
Après, je n'ai qu'une carte 47J53a. et une Pic32 Pinguino otg c'est sur elles que je test mon programme. Sur les autres l'exécutable est peut-être erroné.
Reply
10-09-2014, 08:13 AM, (This post was last modified: 10-09-2014, 08:16 AM by regis.)
#13
RE: Impossible de compiler (Linux MInt 17)
@ypelletier
J'aurais du m'en douter mais les binaires gputils ne sont pas non plus executables sur ta machine, ceci devrait résoudre l'affaire :

sudo chmod a+x /usr/bin/gp*

NB : j'attends la résolution définitive de ton problème pour publier une mise à jour des paquets, cela ne devrait donc plus être un soucis à l'avenir.

@xapon66
Merci. Bon à savoir. Tu peux faire un sdcc -v pour connaitre la version ?
It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
10-09-2014, 11:34 AM,
#14
RE: Impossible de compiler (Linux MInt 17)
Le problème est réglé! :-)

Merci Régis!
Reply
10-09-2014, 11:49 AM,
#15
RE: Impossible de compiler (Linux MInt 17)
Smile
It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
13-09-2014, 09:09 PM,
#16
RE: [Résolu] Impossible de compiler (Linux Mint 17)
(10-09-2014, 11:49 AM)regis Wrote: @xapon66
Merci. Bon à savoir. Tu peux faire un sdcc -v pour connaitre la version ?

bash-4.2$ sdcc -v
SDCC : mcs51/z80/z180/r2k/r3ka/gbz80/tlcs90/ds390/pic16/pic14/TININative/ds400/hc08/s08/stm8 3.4.0 #8981 (Aug 18 2014) (Linux)
Reply
13-10-2014, 08:24 PM,
#17
RE: [Résolu] Impossible de compiler (Linux Mint 17)
(10-09-2014, 11:34 AM)ypelletier Wrote: Le problème est réglé!    :-)

Merci Régis!

Bonsoir,

Si le problème est réglées pour les cartes 8bit pour les 32 il reste entier.

Lors de l'installation un message d'erreur:

 pinguino-linux64-gcc-mips-elf dépend de libstdc++6 (>= 4.9) ; cependant :

  La version de libstdc++6:amd64 sur le système est 4.8.2-19ubuntu1.

"dpkg: error processing package pinguino-linux64-gcc-mips-elf (--install):
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 pinguino-linux64-gcc-mips-elf"

Conséquence pas de compilateur pour 32 bit.

Installation sous Mint 17 64bit de cet après midi tel que dispo sur le serveur Mint.

Ou trouver "libstdc++6 (>= 4.9" ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)