Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Win 7 driver again
26-09-2014, 02:35 PM, (This post was last modified: 26-09-2014, 02:36 PM by pingotg.)
RE: Win 7 driver again
Good progress!

I know zadig works (I've actually used it on Win7 32bit for libusb), but can't be sure it is what you want. I would try it instead of all that funny renaming stuff but there again I'm on Linux LOL

26-09-2014, 03:20 PM,
RE: Win 7 driver again
Hello Kriss,
I read your PM yesterday.
I replied in the troubleshooting forum because I did not succeed to attach my screen captures.
To reply to your new question relating to the libusb0 files :
Yesterday investigating problems between Python and libusb/Pinguino I was very surprised to find in Windows\System32 :
libusb0.dll (75ko) and drivers\libusb0.sys (52ko), both found in folder libusb-win32-bin-\amd64

and in Windows\SysWOW64:
libusb0.dll (75ko), the same as above and drivers\ibusb0.sys (47ko), found in folder libusb-win32-bin-\x86.

I tried to install the x86 elements in System32 and the amd64 ones in SysWOW64 and it was a real catastrophe : a part of my usb devices, ports LPT1 and COM, a USB hub controller did not work at all.

Coming back at the previous installation all became normal. Now I stop to experiment !!!

Bye bye
26-09-2014, 03:30 PM,
RE: Win 7 driver again
Hehe here's the point where I am (is it english ?)

I used Zadig, to change driver from usbser to WinUsb32. My COM4 virtual port wen t down, and The various libusb tests still failed.

I unnistalled, and finally had a COM5 to reappear, but still no winusb-32 working

Tried to desinstall reinstall winusb (btw not so sure how to do that ? there would be 3 files ? according to the readme ... 2 libusb0.dll, 1usb0.sys) no sure if reboot needed.

After various tries COM5 disappeared (went down so I uninstalled it)

Then came .. COM6 lol

A terminal on COM6 works, but winusb32 seems weird . after reinstalling Libusb32 it MAY be OK, but I can't be sure atm it is.
the Test (Win) program from libusb32 seems to work and says :

DLL version:
Driver version:

bus/device idVendor/idProduct
bus-0/\\.\libusb0-0001--0x04d8-0x000a 04D8/000A
- Manufacturer : Microchip Technology Inc.
- Product : CDC RS-232 Emulation Demo
bLength: 18
bDescriptorType: 01h
bcdUSB: 0200h
bDeviceClass: 02h
bDeviceSubClass: 00h
bDeviceProtocol: 00h
bMaxPacketSize0: 08h
idVendor: 04D8h
idProduct: 000Ah
bcdDevice: 0100h
iManufacturer: 1
iProduct: 2
iSerialNumber: 0
bNumConfigurations: 1
wTotalLength: 67
bNumInterfaces: 2
bConfigurationValue: 1
iConfiguration: 0
bmAttributes: c0h
MaxPower: 50
bInterfaceNumber: 0
bAlternateSetting: 0
bNumEndpoints: 1
bInterfaceClass: 2
bInterfaceSubClass: 2
bInterfaceProtocol: 1
iInterface: 0
bEndpointAddress: 81h
bmAttributes: 03h
wMaxPacketSize: 10
bInterval: 1
bRefresh: 0
bSynchAddress: 0
bInterfaceNumber: 1
bAlternateSetting: 0
bNumEndpoints: 2
bInterfaceClass: 10
bInterfaceSubClass: 0
bInterfaceProtocol: 0
iInterface: 0
bEndpointAddress: 02h
bmAttributes: 02h
wMaxPacketSize: 64
bInterval: 0
bRefresh: 0
bSynchAddress: 0
bEndpointAddress: 82h
bmAttributes: 02h
wMaxPacketSize: 64
bInterval: 0
bRefresh: 0
bSynchAddress: 0

BUT the sample program that I use to read the usb bus (which just reads the buss just like the printf sample writes on the bus, very simple) doesnt read a thing...

What can I use prove winusb works (to read usb cdc data) (product vendor 4D8 product ID 0A)
26-09-2014, 04:20 PM,
RE: Win 7 driver again
Looks to be working.

Just use libusb APIs, if that's what you want, I suppose.

26-09-2014, 07:37 PM, (This post was last modified: 26-09-2014, 07:43 PM by KrissNC.)
RE: Win 7 driver again

My libusb 1.2.6 works fine I can prove it !

My c# code from winusbDotnet says :
UsbEndpointReader reader = MyUsbDevice.OpenEndpointReader(ReadEndpointID.Ep01);
ReadEndpointID.Ep01 is an enumeration that starts at 129 (and goes to 143 (ep15))

That 129 rang(rung ? forgot my irregular verbs damnit) a bell to me : isnt 128 80h ? then 129 would be 81H ... didn't I read 81H somewhere ? I did ! bEndpointAddress: 81h in the usb driver text posted before...
But wait I can see 81H(which doesn't work) but also 82H in the text ... lets try with 82H and put Ep02 instead of Ep01 ...  and BAM ! It works !

So atm, I'm able to talk with my pinguino board from c#(visual studio), (at least to read but I guess I'll be able to write too...), which opens me the capacity to send GCode to drive a CNC... (that's my future story Wink

Again thanks a ton for your help.

Attached Files Thumbnail(s)
26-09-2014, 09:01 PM,
RE: Win 7 driver again

Well done for being so persistent.


Forum Jump:

Users browsing this thread: 1 Guest(s)