Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Arch Linux IDE Problem
01-10-2014, 01:52 PM,
#1
Arch Linux IDE Problem
Hello,

i have a problem with the Pingunio IDE. I am using Arch Linux and the IDE don't start.

Error Message:

Code:
Traceback (most recent call last):
 File "./pinguino.py", line 98, in main
   app = MyApp()
 File "./pinguino.py", line 75, in __init__
   wx.App.__init__(self, redirect=True, filename="pinguinoPanic")
 File "/usr/lib/python2.7/site-packages/wx-3.0-gtk2/wx/_core.py", line 8628, in __init__
   self._BootstrapApp()
 File "/usr/lib/python2.7/site-packages/wx-3.0-gtk2/wx/_core.py", line 8196, in _BootstrapApp
   return _core_.PyApp__BootstrapApp(*args, **kwargs)
 File "./pinguino.py", line 85, in OnInit
   splash = MySplashScreen()
 File "./pinguino.py", line 38, in __init__
   memDC.SetTextForeground(wx.BLACK)
 File "/usr/lib/python2.7/site-packages/wx-3.0-gtk2/wx/_gdi.py", line 4391, in SetTextForeground
   return _gdi_.DC_SetTextForeground(*args, **kwargs)
PyAssertionError: C++ assertion "IsOk()" failed at ./src/gtk/dcclient.cpp(1831) in SetTextForeground(): invalid window dc

Pingunio.log:

Code:
Pinguino started at Wed Oct  1 13:50:08 2014

release: 3.16.3-1-ARCH
dist:  
system: Linux
win32_ver:  
processor:


check OS and compilers
System host is GNU/Linux
8-bit compiler OK.
32-bit compiler OK.

check Pinguino modules
wxgui/pinguino.py found
wxgui/uploader/__init__.py found
wxgui/uploader/uploader.py found
wxgui/uploader/uploader8.py found
wxgui/uploader/uploaderMCC.py found
wxgui/uploader/uploaderVSC.py found
wxgui/uploader/autodetect.py found
wxgui/uploader/uploaderDLN.py found
wxgui/__init__.py found
wxgui/_trad.py found
wxgui/editor/events.py found
wxgui/editor/preferences.py found
wxgui/editor/__init__.py found
wxgui/editor/constants.py found
wxgui/editor/experimental.py found
wxgui/editor/editeur.py found
wxgui/editor/stdout.py found
wxgui/editor/autocompleter.py found
wxgui/editor/board_selector.py found
wxgui/editor/get_config.py found
wxgui/editor/funtions_help.py found
wxgui/editor/load_features.py found
wxgui/editor/dic.py found
wxgui/editor/frames/__init__.py found
wxgui/editor/frames/framesX4.py found
wxgui/editor/frames/gettext.py found
wxgui/editor/lateral_tool_area/__init__.py found
wxgui/editor/lateral_tool_area/dock_searchReplace.py found
wxgui/editor/lateral_tool_area/dock_documents.py found
wxgui/editor/lateral_tool_area/dock_files.py found
wxgui/editor/general.py found
wxgui/boards.py found
wxgui/argparse.py found
wxgui/check.py found
python_lib/usb found
python_lib/importlib found

check Python version
Python version is OK (>=2.5)

check Python modules
wxPython successfully loaded
PyShutil successfully loaded
subprocess successfully loaded
gettext successfully loaded
locale successfully loaded
webbrowser successfully loaded
threading successfully loaded

Everything is OK.

The PingunioPanic file is empty.

What should I do?

Thanks,

Sauron17
Reply
01-10-2014, 02:59 PM,
#2
RE: Arch Linux IDE Problem
Does it happen on all versions of ArchLinux? All word lengths? With/without gnome/kde?

I'm thinking some more info would be worth posting.

John
Reply
01-10-2014, 03:37 PM, (This post was last modified: 01-10-2014, 04:51 PM by Sauron17.)
#3
RE: Arch Linux IDE Problem
Edit: I solved the problem with reinstalling wxpython.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)