Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't get CDC to work.
22-09-2015, 11:38 PM, (This post was last modified: 22-09-2015, 11:58 PM by B4lfiz4r.)
#1
Can't get CDC to work.
Hey, I am working with the following example:
Code:
// USB/CDC/Printf.pde
// Output on Linux : sudo cat /dev/ttyACM0
// Outout on Windows :

float f=0;

void setup()
{
   pinMode(USERLED, OUTPUT);
}

void loop()
{
   CDC.printf("float=%.1f \r\n", f);  // 1 digit after decimal comma
   f = f + 0.1;
   toggle(USERLED);
   delay(500);
}

My device is visible but I am not able to find the drivers.

Where are the CDC drivers in the pinguino-11.2015.02.02-setup.exe release?



according to the wiki, they should be in

Code:
The driver for the PIC18F4550 device is in the Pinguino IDE Folder
..\PINGUINO\x4-easy-rev959\extra\drivers\CDC
but I am not able to find them.



Also:

Code:
Prepare the connection to the Pinguino device by installing the driver from: http://linux.gatewaybbs.com.au/~zapper/EFIlive/USB%20Cable%20driver/


How to install this driver? That's not the USB driver, Windows can'tr renognize it.

Any help is welcome..


UPDATE: 
I have found the driver on the web, I added it as a attachment.

But I still don't know why I don't have "Debug" under "Pinguino" tab, as stated on wiki. Can anyone help?

Code:
Step 4:
 Select Menu->Pinguino->Debug Mode->USB CDC And on the bottom section the port x on which the device is connected and there you go:


Attached Files
.zip   x4-easy-rev959_DRIVER_CDC.zip (Size: 6.48 KB / Downloads: 4)
Reply
23-09-2015, 04:29 PM,
#2
RE: Can't get CDC to work.
Debug mode was  available with version x.4 dated december 2012.
In version april 2013 it was not more. I can't tell why.
Bye
André
Reply
03-10-2015, 11:09 AM,
#3
RE: Can't get CDC to work.
Well, I've got CDC working with Hyperterminal, but somehow it works only SOMETIMES and in the most of the cases I'm getting strange errors like "port in use", or "the device is not working" etc. Is this a Hyperterminal issue or serial emulation bug?

Termite 3.2 also does not work more often than works.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)