Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
IDE Problems Compiler problems
27-12-2015, 05:58 PM, (This post was last modified: 27-12-2015, 10:06 PM by Mark2016.)
#1
Smile  IDE Problems Compiler problems

.txt   debug.txt (Size: 392 bytes / Downloads: 1)
Good afternoon all Date 27th Dec 2015 GMT 15:43

Could this possibly be , " ALL I DON'T WANT FOR XMAS IS A PIC32 -Mx220 board " because none of their so called IDE's or will compile on Linux Ubuntu 12.04 "

PS I have now made reference to this also on face-book with some of our students at uni who might be able to throw light on this its that frustrating "

This is quite bad really You can picture the frustration with this for people on XMAS day cant you ?? " , Lovely !! And WHATS MORE WHICH IS NO JOKE AT ALL !!!! People cant get their monies back or returned on this item because their site says ,"No refunds "

Ok £15.00 or what ever not a great deal of money but it is though when you consider just how many people went and bought these in good faith not to mention that damage that this does to companies such as Microchip or to retailers wishing to sell these on or in fact to the company known as Olimex whom advertise at http://www.olimex.com or your ultimate target clients and that is whom ??

Correct University students who have very little to play with or college students or just plain and simple the ordinary man in the streets wanting to learn or encourage his , her youngsters to take up something decent !!

So its not really that clever is it Its downright disgusting isn't it ?? Read On please ?

I am currently running Ubuntu 12.04  with  GCC version 4.9.2  and am having no end of problems trying to set up the python ide for compiling for the pic 32 MX220


Ive also tried as suggested the script both Zinstaller (graphical version ) , also as recommended ," installer.sh fully automated , ha, ha, for Linux text version " for setting up the IDE with p32 and p8 compilers

Eventually I decide lets try the Github version using the normal git clone routine


Everything seems to function until try to compile using one of the examples , " the blink.pde" , ho, ho , Yes it finds the library files, no worries , looking good so far or so it would seem doodle doodle do de de

Then the compiler gets all the way to end and exits with error code2 complaining that you should view stdout which I have, " Aooo my golly googles "

The  error reported is as follows

Quote:/usr/bin/../lib/gcc/mips-elf/4.9.2/../../../../mips-elf/bin/ld: cannot find -lgcc
/usr/bin/../lib/gcc/mips-elf/4.9.2/../../../../mips-elf/bin/ld: cannot find -lgcc
collect2: error: ld returned 1 exit status

Wait a minute its telling me I need libgcc

Hmmmm Well Ive just re installed gcc-4.9 so it must have libgcc Or does it ?

Quick locate reveals that or using the find command tells me all sorts about libgcc lots of different versions which one is it ," scratch , scratch " , lots of hair missing and at over 8 hours wracking my brain here

Definitely not looking to goodly at all this, never mind keep trying

Path to libgcc
/lib/i386-linux-gnu/libgcc_s.so.1 , " Looks as though what ever its complaining about is there possibly and possibly not , still none the wiser here "



On top of this the software manager shows a lovely red no entry sign (The red stripe story of course ) and says the following , " partial upgrade a mention about 8 packages required and click accept , " must be telling the truth thats obviously what I need "

Super news all installed properly or so it would seem !!

Got to be all be working by now and low and behold still same problem and shows then the next glorious no entry sign again !! "Oh dear not again"

Ok lets see What ?? , "Partial upgrade again " ,  Aaah wonder it wants this time ?

Then says , "removing software  pinguino-ide " Oh No this cant be happening !!

Uhm now what ??



As a further references I have followed Wiki to the letter and also checked this link here to see what the ide actually does (Normally wiki is fairly good and reliable however I cant get their instructions to work at all for some reason on this one at all at all at all ) see the following

https://code.google.com/p/pinguino32/sou...n352&r=352

Or on github !!

I must be doing wrong here or I ask myself am i ? Perhaps not ? Perhaps the wrong version sdcc don't quite know thats also for 8 bit mcu's by the way Brilliant so far no hex fantastic board but haven't got to the final testing stage yet Does it actually work ??

I also as a matter of interest tried your snapshot as an ide located at http://www.pinguino.cc/download/ide/ , "Uhm yes from your site no less "

And extracted this using the command ."tar --lzma -xvf " so that the installation was where the snapshot was downloaded too which installs to a folder named x.4

Great that works at least must be improving

Supposedly this should start with the script named ,"pinguino_start.sh" This too has an option for setting the type of board although again no 32 bit boards are options via selective radio buttons < " Oh hell yet another floppy doppy "

This doesn't respond to any of the menu events example open file or others menu options Brillaint now what have they done here I wonder ??

The frames present on the gui will not resize either in other words you cant open the frame up even with window expanded It will however close on the close window event , " I suppose thats something must have got something right at last managed the close window event " 0.5 out of 10 so far

Interesting to note at this point that the Arduino IDE for Ubuntu 12.04 will run

MPLABX will also run
However not the recommended python shell , ide , although you will be pleased to know that the git hub version 11 does at least open and respond to events however for reasons mentioned above will not compile to hex

Any ideas at all greatly appreciated or any suggestions ? Please see stdout and debug files

Just as well i didn't give this to someone at XMAS isn't it or import many into the country I don't think they would have been to pleased either


Thanking you all Any suggestions wonderfully accepted with real solutions

Mark


Attached Files
.txt   stdout.txt (Size: 392 bytes / Downloads: 0)
Reply
28-12-2015, 04:40 PM,
#2
RE: IDE Problems Compiler problems
Oh, have just found your post in Olimex forum... have a look...

John
Reply
30-12-2015, 11:48 PM,
#3
RE: IDE Problems Compiler problems
(28-12-2015, 04:40 PM)pingotg Wrote: Oh, have just found your post in Olimex forum...  have a look...

John

Good I'm glad you have

Do you have any suggestions more to the point !! Ive managed to get this running on windows 7 however what they don't tell you is you still need another driver no mention of this anywhere either so that you can see the USB port as a virtual serial port Fortunately windows 7 finds that for you by scouting Microsoft website

Not exactly a brilliant start is it truthfully and the instructions are appalling  Never mind lost of improvement required Lots and lots of it especially if you wish to stay in the market and be slightly competitive with what is essentially quite a good board Well over 8-12 hours to find this much out Im not to impressed as you can gather
Reply
31-12-2015, 04:29 AM,
#4
RE: IDE Problems Compiler problems
I documented this and several other shortcomings on this forum but the the sysadmin apparently dislikes the criticism and removed it along with another individuals remarks.

A copy of the same post is located here...

https://www.olimex.com/forum/index.php?t...3#msg20473

I would suggest you read it in order to save yourself some head scratching.
----------------
Thanks,
j
wzumwalt
 (\__/)
 (='.'=)
 (")_(")
Reply
31-12-2015, 10:43 AM,
#5
RE: IDE Problems Compiler problems
Mark2016 - I figured you'd read my reply there...

John
Reply
01-01-2016, 12:48 PM,
#6
RE: IDE Problems Compiler problems
(31-12-2015, 04:29 AM)jwzumwalt Wrote: I documented this and several other shortcomings on this forum but the the sysadmin apparently dislikes the criticism and removed it along with another individuals remarks.

A copy of the same post is located here...

https://www.olimex.com/forum/index.php?t...3#msg20473

I would suggest you read it in order to save yourself some head scratching.

Well to be honest i shouldn't have to scratch heads

I expect there should be a little work involved after all it is open source not that this should be any excuse , we are buying Olimex boards  and that money supposedly is paid to that project so as to improve , produce , something that is professional and pays peoples wages to do so 

On the basis that these are sold on an international basis thats quite a large sum of money,  besides which there are laws regarding trading standards which need to be adhered to whether you i or anyone likes this or not 

Part of that law is that as company whether open source or not your provide  a working product hence if you advertise that this ide works and is designed compatible with that board on Linux OS then as such it must  be operational

Other wise simply you face legal action are taken to court for false advertising and misleading the public which can and does amount to serious  fines  often closure of said companies with insolvency and other clients who cue up to do similar Not truthfully the best answer to many a problem such as this

I am also by and large a very patient man and try to give people the opportunity to put things right 

I'm fully aware this is no easy task in fact its very difficult and equally know just how pressure others can place not only companies , but also equally its staff who may work for them from time to time often  the controlling influences  are to say  the very least real little pterodactyls[url=https://www.google.co.uk/search?client=ubuntu&hs=B3y&channel=fs&q=pterodactyls&spell=1&sa=X&ved=0ahUKEwjssNHfsojKAhUCWhQKHYg5DGMQvwUIGigA&biw=1143&bih=749&dpr=0.9][/url] , Allosaurus , often with huge fangs and poisonous traits

I did read your comments regards this and Ive tried the download direct from this site  , also open source ,

As i said i can get every other ide to function  Ive even tried MPIDE  but of course MPIDE does not recognize the USB port and I cannot find any instructions that would enable this to work on Linux  and my knowledge is not sufficient that i could write a USB driver for Linux let alone a compiler other wise Id be doing it  beleive you me

This does not implicate  I'm  not interested in doing this either  I am ,  but ..... of course their is always the but but of this , similar to that of a rifle being plunged into your face  which  quite frankly the response  to these problems are, and where some decency should be observed


At the very minimum part suggestion other than thank you very much ,had your money , tada  story, as this affects many who are equally , having read you comments too,  very unhappy

Cant truthfully say I blame them either  to be honest

Equally  mentioned this does not enhance microchip in any way , creates bad business and also bad attitudes all round with total distrust at the end

This is not good for anyone at all,  least of all the people that work within your domain , other professionals and neither does this create a professional attitude or reasonable respect for each other as a  group

The board itself and ideology behind such an idea is how ever very good but  however a miss is as good as a  mile

One half working the other half not  , is classified as a failure and so must be rectified

If you are able to supply informations that would enhance this or suggestions on how to get round this problem would you please advice

Suggestions , guidelines, better instructions even tutorials or how too's would be advantageous


Thanking you

Mark2016
Reply
01-01-2016, 09:31 PM, (This post was last modified: 01-01-2016, 10:15 PM by pingotg.)
#7
RE: IDE Problems Compiler problems
See my previous reply.

(It should be obvous that people not controlled by Olimex have broken a working software project and/or you're using a different software combination (OS+IDE etc) than was used when it worked. I agree it's annoying and daft but that's what some people do - they break things carelessly. I do think you might actually try my reply though.)

John
Reply
02-01-2016, 12:52 PM,
#8
RE: IDE Problems Compiler problems
(01-01-2016, 09:31 PM)pingotg Wrote: See my previous reply.

(It should be obvous that people not controlled by Olimex have broken a working software project and/or you're using a different software combination (OS+IDE etc) than was used when it worked.  I agree it's annoying and daft but that's what some people do - they break things carelessly.  I do think you might actually try my reply though.)

John

Hi John

Firstly Happy new year to you


I have read through your reply I  could do with some guidance or a " how to" , if you like on using MPIDE with this board  I have got MPIDE installed and up on running on Linux I just cant fathom out  how to finally upload the hex file to the board So everything working to that point

Ive also created UDEV files for the board  with permissions of 0666  but having read through MPIDE only see's serial port hence you cannot upload unless you use ICSP or you would have build a separate
serial FTDI bourd which , well, I don't truthfully want to do although I could if I absolutely had too so I'm wondering how you get round that one without having to do this


I run two systems namley , windows and Linux for various reasons , but i far prefer Linux now however if you could provide a , " how too " on uploading this to the USB port in conjunction with MPIDE that would really be of benefit

I will look into what they have done with this as I see the windows installation  works so I  might investigate  the standard out as and when i get some space to breath that is and possibly try and rewrite the IDE myself or with some help of others  thats if anyone is possibly interested (group project maybe )


I'm not to bad with programming , have worked with java , c# , mono , c++ and a little python which to be honest isn't that difficult to grasp  but could always do with some guidance with this

Thanking you

Mark2016
Reply
02-01-2016, 06:53 PM,
#9
RE: IDE Problems Compiler problems
My reply is not about MPIDE, which is not an IDE from this site is it?

John
Reply
02-01-2016, 08:45 PM,
#10
RE: IDE Problems Compiler problems
(02-01-2016, 06:53 PM)pingotg Wrote: My reply is not about MPIDE, which is not an IDE from this site is it?

John

Quote:From your post John This works and runs but only has serial ports communications  tty0 in other words is all this see's

MPIDE
- Rating (7 out of 10): http://chipkit.net/wpcproduct/mpide/

My evaluation of MPIDE is based upon using it for non-pinguino dev boards. However, previous experience with it has been good.
+ The most stable IDE for programming a PINGUINO MICRO I tried.
+ The forum/user group is very active and support is very good.
+ includes virtual serial terminal.
+ sysadmin and experts do their best to support Pinguino questions.

- No command documentation.
- Does not support line numbers or command completion.
- MPIDE  requires a custom boot loader to be installed before Pinguino programs can be used.
Quote:First subject on your post  John #1

Pinguino-V11
- Rating (3 out of 10): http://pinguino.cc/ Pinguino-V11 is by far the nicest IDE concept I have seen.


BUT... It is extremely buggy [Image: sad.gif] I tried several versions and they all have bone crippling problems. From what I can tell, the Linux version may be OK but I tried it under Win7 64bit and it is pretty much useless. If this IDE was stable, it could be 10 stars!
+ It is the cleanest looking, feature rich IDE of all the open source I have tried.
+ There is an active blog and forum, questions are answered promptly
+ Supports line numbers and command completion.

There are too numerous bugs to mention, but here are a few.
- Lacks virtual com.
- Generic example code, not tested for specific cpu.
- If a program name is the same as an existing file or dir name, it will not compile.
- If a file is saved in a new directory and file name, the compiler still tries to edit and compile the old program.
- The name, "Pinguino IDE" is confusing to distinguish from generic software - it needs a name.
- It lacks a virtual com serial terminal.
- "Command Completion" stops working unexpectedly. You must reboot the computer to get it to work again.
- It is missing much of the command documentation
- Commands are not universal between CPU implementations, so examples do not always work.
- No significant development of the IDE or updates to the WIKI, criticism on the forum is deleted.

So it is from your post but  software not from this site This sites version does not work  I have tried this its non responsive to events  Simply out it doesn't work !!

I cant believe I'm having to go through all of this to try and get some response from persons in an attempt to actually get this to work on Linux Ubuntu 12.04 machines

Is it my language or is that i don't explain this correctly

Does any one else know of this problem and how to get t round this  apart from use windows please ??



Cheers !!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)