Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New installer on W7 64bits
01-04-2016, 08:01 PM,
#1
New installer on W7 64bits
Hello,

Looking for upgrade on pinguino IDE, i runned the new installer, everything went fine and at the end, when i double click on the icon, a dos prompt appears and disappears to fast to see the error.

Is there any place where we can see what went wrong?

Fernando
Reply
01-04-2016, 08:29 PM,
#2
RE: New installer on W7 64bits
Well it's something like this:

Traceback (most recent call last):
File: "pinguino.py", line 142. in (module)
From PySide import QtCore
ImportError: DLL load failed: xi não ú uma aplicação de Win32 válida

This was shoot with an old digital camera.

Fernando
Reply
04-04-2016, 02:30 PM,
#3
RE: New installer on W7 64bits
It is like your OS and Python don't have the same architecture.
Please, look at the files downloaded in the directory where you saved the installer.
Do you have python-2.7.10.msi or python-2.7.10.amd64.msi ? You should have the last one.
If not, try to download it on your own, remove the 32-bit version and install the 64-bit instead.
It is possible that Win7-64 is not well detected by the installer.
If you run it again, you should see a message about your OS in the console window, like :
$(msg_your_system_is) Microsoft Windows $os_version ($os_platform).
What do you get ?
It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
04-04-2016, 07:17 PM,
#4
RE: New installer on W7 64bits
Hello Regis, and thanks for the help.

My system is:
W7 Ultimate SP1 64 bits
AMD PhenomII X4 965 3.4Ghz
8G Memory

The installer detects a 64bit system, it's downloading python-2.7.10.amd64.msi

I've runned the installer and it does not explicitly quotes the system i have, but it installs everything for 64bits. (LibUSB drivers for 32).

The message when i try to run pinguino ide stays the same. Sad
Reply
04-04-2016, 09:09 PM,
#5
RE: New installer on W7 64bits
Then you should dowload and install PySide for Win7-64.
However I did all the test on Win10-64 and I've had no architecture issue ...
It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
06-04-2016, 10:12 PM,
#6
RE: New installer on W7 64bits
Hello Regis,

Thanks for the help, now it works.

The message that appears in the console is this:

"Python 2.7.10 (default, May 23 2015, 09:44:00) [MSC v.1500 64 bit (AMD64)] on win32"

I had also installed vcredist_x64.exe (Visual C++), because of a missing dll.

My wife's computer, a win8 64, intel, also happened the same error, and the resolution that you said worked, but i also had to install vcredist_x64.

So the installer is not recognising w7 64 and w8 64 well.

Thanks again.

Fernando
Reply
07-04-2016, 10:52 AM,
#7
RE: New installer on W7 64bits
As PySide is installed by Pip, I thought Pip did not install the right version of PySide on W7-64 or W8-64 ...
I took a look at the Pip site and I read Pip is already installed when Python version > 2.7.9.
The Installer got Pip from here : https://bootstrap.pypa.io/get-pip.py and installed it on Windows.
Now the installer will check if Pip is installed and and will only proceed to a simple update if it is :

> python -m pip install -U pip



Thank you for your help.
It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
11-04-2016, 07:43 PM,
#8
RE: New installer on W7 64bits
Hi,

I have the same problem:

(01-04-2016, 08:29 PM)fpeixeiro Wrote: Well it's something like this:

Traceback (most recent call last):
File: "pinguino.py", line 142. in (module)
From PySide import QtCore
ImportError: DLL load failed: xi não ú uma aplicação de Win32 válida

This was shoot with an old digital camera.

Fernando

It seems to be a problem of a pre-installed version of python (with another bit version, like Regis said). In my case, the installer doesn't detect the other version (2.7.10-32bit (64-bit too)). (It is installed on 64 bit system, but there is usually no problem using the 32 bit Version). After uninstalling the 32bit version (There are some scripts and moduls left) and installing the 64 bit one, this error occurs. Uninstalling the 64 bit version and installing the 32 bit again, then it works. So it seems that installing the 64 bit version is not necessary, but the installer force to do or stops the installation. Maybe it is better get a choice or check for both, 32 and 64 bit?

Regards Patrick
Reply
13-04-2016, 08:25 AM,
#9
RE: New installer on W7 64bits
Did you try with the latest Windows Installer (v1.7.0.7) ?
http://www.pinguino.cc/download.php
It is easier to complain than it is to do, but it is better to do than it is to complain.
Reply
17-04-2016, 08:58 PM,
#10
RE: New installer on W7 64bits
Hello regis,

i tried 1.7.0.6, and 1.7.0.7 today. Now it detects the Python version, and installs and starts without any problem.

Thank you,

Regards Patrick
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)