Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pinguino's Graphical mode does not work at all
13-04-2017, 12:49 PM, (This post was last modified: 13-04-2017, 12:50 PM by Leonardo.)
#1
Pinguino's Graphical mode does not work at all
Hi all,

I have recently installed the updated release of the Pinguino IDE V11.

First of all, I had a couple of minor issues with theinstallation paths of the compilers, wich by default are wrong in the user/pinguino.conf file. Second, I tried the Graphical mode in the IDE and it doesn't work at all.

I have found three mayor problems:

- When you press the compile button, the IDE indicates that the procces was completed without error, but there is no compiled files (.hex file).

- When you press the download button, the IDE indicates that the download was succeful, even though there is no board connected to the USB port.

- When you save a graphical design and then re-open the file, or just reload the IDE, the complete graphical estructure is shattered. You have to re-align and re-arrange all the blocks.

The graphical mode is a wonderful tool for teaching microcontroller programming to young students who have just started to learn programming, robotics and electronics. It is a pity that it does not work.

I attach an image showing the graphical mode shattered.

   

Is there any way to solve these problems?
What I can do?
How I can help?

I have used the installer versión 1.7.1.3 in a windows 7 x64 environment.

Best regards,

Leonardo.

P.D.: There is a problem with the language selection of the IDE. It only installs in English language, even though the Spanish languaje was selected in the install dialog. There is any way to solve it?
Reply
23-04-2017, 11:25 AM,
#2
RE: Pinguino's Graphical mode does not work at all
Hi all,

To whom it may be interested in.
I managed to solve the issue with the graphical mode by installing the Pinguino IDE version V12 (released as "testing").

Best regards,

Leonardo
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)